springboot2.5 @Validated失效问

java codefuture
最新的一个项目用到了springboot2.3.1,依旧按照以前的写法,引入依赖,Bean中使用@NotNull、@NotBlank等,最后却失效了,尝试了很多方法,如替换为@Valid、两者结合使用等,均不起作用,最后Google找到了原因

 

原来,springboot在2.3之后,spring-boot-starter-web的依赖项已经去除了validate依赖

<dependency>
      <groupId>org.hibernate.validator</groupId>
      <artifactId>hibernate-validator</artifactId>
      <version>6.0.17.Final</version>
      <scope>compile</scope>
 </dependency>
 

转载请注明:码出未来-php,java,架构,职场 » springboot2.5 @Validated失效问

喜欢 ()or分享 (0)
留言与评论(共有 0 条评论)
   
验证码: